vim编辑文件提示'readonly' option is set (add ! to override)和Can't open file

今天在编辑项目配置文件的时候使用

vim config.php

在:wq保存的时候提示'readonly' option is set (add ! to override),意思就是这是个只读文件,如果需要覆盖需要使用:wq!进行保存,但是当我使用:wq!保存的时候又提示我Can't open file for writing,意思就是不能打开写文件,这种情况可能是权限不足,或者被其他程序占用,如果是权限不足使用如下命令:

sudo vim config.php

然后使用:wq!成功保存